MASKS AND CHANNELS

Lesson overview

in this lesson, you'll learn how to do the following:

« Create a mask to removea subject from a background.
+ Refine amaskto include complex edges.

« Create a quick rmask to make changes to a selected area.
. Edit a mask using the Properties panel.

« Manipulate an image using puppet Warp-

+ Saveaselection asan alpha channel.

« View a mask using the Channels panel.

+ Loadachannelasa selection.

. [solate a channel to make specific image changes.

This lesson will take about an hour to complete. Download the Lesson06
project files from the Lesson & Update Files tab on your Account page
at www.peachpit.com, if you haven't already done so. As you work on this
lesson, you'll preserve the start files. If you need to restore the start files,
download them from your Account page-
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Use masks to lsolate and manipulate specific pars of
an image. The cutout portion of amask can be altered,
tut the area surrounding the cutoutis protected from
change. You can create a lemporary mask to use once,
of you can save masks for repeated use,




Working with masks and channels
just as masking tape protects

paint when a house is painted. When you create a mask

ea you haven't selected is masked, ot protected from
ve time-consuming selections and then

ks for other complex editing tasks—for
o0 an image.

In Photoshop, masks isolate and protect parts of an image,

window panes ot trim from
based on a selection, the ar
editing. With masks, you can create and sa
use them again. In addition, you can use mas
to apply color changes oF filter effects t

In Photoshop, you can make temporary masks, called guick masks, or you can
hem as special grayscale channels called alpha

create permanent masks and store t
channels. Photoshop also uses chann an image's color information.
Unlike layers, channels do not print. ew and work

with alpha channels.

example,

els to store
You use the Channels panel to vi

d white reveals. As in life, rarely
depending on the gray
0 is the value for white,

g is that black hides an
ite. Shades of gray partially hide,
r black, hiding artwork completely;

A key concept in maskin
is anything black and wh
levels (255 is the value fo
revealing artwork completely).

Getting started

L]
First, you'll view the image that you'll cr:

atel
05) to restore the default

eate using masks and channels.

y hold down Ctrl+Alt+Shift (Windows)

1 Start Photoshop, and then immedi
preferences. (See

ot Command+Option+Shift {Mac
“Restoring default preferences” on page 4.

2 When prompted, click Yes to delete the Adobe Photoshop Settings file.

Adobe Bridge.

Choose File > Browse In Bridge to open
the Bridge window. Select the Lessons

@ Note: If Bridgeisn't 3

installed, you'll be

prompted to install 4 Click the Favorites tab on the left side of

it when you chocse folder, and then double-click the Lesson06 folder in the Content panel.

Browse In Bridge.

For more information, 5 Study the 06End.psd file. To enlarge the thumbnail so that you can see it more
clearly, move the thumbnail slider at the bottom of the Bridge window to the right.

see page 3.
@ model for the cover was photo-

azine cover. Th
fine Mask

In this lesson, you'll create a Mag;
graphed in front of a different background. You'll use masking and the Re

feature to place the model on the appropriate background.

6 Double-click the 06Start.psd thumbnail to open it in Photoshop. Click
OK if you see an Embedded Profile Mismatch dialog box.
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Creating a mask

you'll use the Quick Selection tool to create the initial mask in order to separate

the model from the background.

1 Choose File > Save As, rename the file 06Working.psd, and click Save. Click
OK if the Photoshop Format Options dialog box appears.

Saving a working version of the file lets you return to the original if you need it.

I Tip: For help making
selections, refer to
Lesson 3, "Working with
Selections.”

2 Sclect the Quick Selection tool (). In the options bar, set up a brush with a size
of 15 px and hardness of 100%.

3 Drag to select the man. It's fairly casy to select his shirt and face, but the hair
is trickier. Don’t worry if the selection isn’t perfect. You'll refine the mask in

the next exercise.

4 At the bottom of the Layers panel, click the Add Layer Mask button (@)
to create a layer mask.
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{ Alpha channels, channel masks, clipping masks, layer masks, vector masks—
what's the difference? In some cases, they're interchangeable: A channel mask can
ask can be converted to a vector mask, and

‘ About masks and masking
i
I

be converted to a layer mask, a layer m
vice versa.
Here's a brief description to help you keep them all straight. What they have in commeon 1
is that they all store selections, and they all let you editan image nondestructively, so 1
you can refum atany time to your original. _
« Analpha channel—also called a mask or selection—is an extra channel
added to an image; It stores selections as grayscale images. You can add alpha
channels to create and store masks.
1 » Alayer maskislikean alpha channel, but it's attached to a specific layer. Alayer
il A ' 4 mask controls which part of a layer is revealed or hidden. it appears asa blank
] thumbnail next to the layer thumbnail in the Layers panel until you add content
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to it; a black outline indicates that it's selected.

e Avectormaskis essentially a layer mask made up of vectors, not pixels.
Resolution-independent, vector masks have crisp edges and are created with
the pen or shape tools. They don't support transparency, so their edges can't be
feathered. Their thumbnails appear the same as layer mask thumbnails.

« Aclipping mask applies to alayer. it confines the influence of an effectto
specific layers, rather than to everything below the Jayer in the layer stack.
Using a clipping mask clips layers to a base layer; only that base layer is affected.
Thumbnails of a clipped layer are indented with a right-angle arrow painting to
the layer below. The name of the clipped base layer is underlined.

« A channel mask restricts editing toa specific channel {for example, a Cyan
channel In a CMYK Image). Channel masks are useful for making intricate,
fringed, or wispy-edged selections. You can create a channel mask based on
a dominant color in an image or a pranounced contrast in an isalated channel,
for example, between the subject and the background.
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1 ) 1 L il panel. Everything outside the selection is transparent, represented by a checker-
Gr s H board pattern. 1
et | 1
s | |
i 1 i'| H F
it |
¢ i |
» I_1
H ] | 'l -
S | -
ey ||| .
i | il ¢
(A
2 138 LESSON 6 Masks and Channels




R S

Refining a mask

The mask is pretty good, but the Quick Selection tool couldn’t quite capture all of
the model's hair. The mask is also a little choppy around the contours of the shirl
and face. You'll smooth the mask, and then fine-tune the area around the hair.

1 Choose Window > Properties to open the Properties panel.
2 Ifitisn't already selected, click the mask on Layer 0 in the Layers panel.
3 In the Properties panel, click Mask Edge. The Refine Mask dialog box opens.

4 Inthe View Mode area of the dialog box, click the arrow next to the preview
window. Choose On Black from the pop-up menu.

The mask appears against a black background, which makes it easier to see the edge

of the white shirt and the face.
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move the sliders to create a smooth,

$ In the Adjust Edge area of the dialog box,
The optimal settings depend on the

| 1 unfeathered edge along the shirt and face.
' selection you created, but they'll probably be similar to ours. We moved the

] Smooth slider to 15 to create a smoother outline, Contrast to 40% to make

EAE the transitions along the selection border more abrupt, and Shift Edge to -8%

‘ b to move the selection border inward and help remove unwanted background
colors from selection edges. (Adjusting Shift Edge to a positive number would

i | |
move the border outward.)

e

6 In the OQutput area of the dialog box, select Decontaminate Colors. Choose

New Layer With Layer Mask from the Qutput To menu.
with the color of fully selected pixels

Decontamninate Colors replaces color fringes
ption requires you to output to a new

| nearby. Because it changes pixel color, this o
layer or document.

{ ! 7 Select the Zoom tool in the Refine Mask dialo

Hal to zoom in so you can see its edges more clearly.

the Refine Mask dialog box. Use it to paint

ins around the lips and the nose. Press the

d the right bracket (}) to increase it.

g box, and then click the face

i |
. :I 1 8 Select the Refine Radius tool (o) in
out any white background that rema
left bracket ({) to decrease the brush size an
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Julieanne Kost is an official Adobe Photoshop evangelist.
Tool tips from the Photoshop
evangelist

Zoom tool shortcuts

Often when editing an image, you'll need to zoomin to work on a detall and then
zoom out again to see the changes in context. Here are several keyboard shortcuts
that make zooming even faster and easier.

« With any tool selected, press Ctrl (Windows) or Command (Mac O5) with the
plus sign {+) to zoom in, o with the minus sign (-) to zoom out.

« Double-click the Zoom tool in the Tools panel to return the image to 100% view.

¢ When Scrubby Zoom is selected in the options bar, just drag the Zoom tool {0
the left to zoom out or drag it to the right to zoom in.

«  Press Alt (Windows) or Option (Mac 05} to change the Zoom In tool to the Zoom
Out tool, and click the area of the image you want to reduce. Each Alt/Option-
click reduces the image by the next preset increment.

9 When you're satisfied with the mask around the face, click OK.

A new layer, named Layer 0 copy, appears in the Layers panel. You'll use this layer
to add the spikes to the mask of the hair.

10 With Layer 0 copy active, click Mask Edge in the Properties panel to open the
Refine Mask dialog box again.

11 From the View pop-up menu, choose On White. The black hair shows up
well against the white matte. If necessary, zoom out or use the Hand tool
to reposition the image so that you can see all of the hair.

12 Select the Refine Radius tool in the Refine Mask dialog box. Press the ] key to
increase the size of the brush. (The options bar displays the brush size; we used
300 px at first.) Then, begin brushing along the top of the hair, high enough to
include the spikes.
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13 Press the [ key a few times to decrease the brush size by about half. Then, paint
along the right side of the head, where the hair is a solid color, to pick up any

small, fine hairs that protrude. :

As you paint, Photoshop refines the mask edge, including the hair, but eliminating
most of the background. If you were painting ona layer mask, the background
would be included, The Refine Mask feature is good, but it's not perfect. You'l
clean up any areas of background that are included with the hair.

14 Select the Erase Refinements tool (&), hidden behind the Refine Radius tool in
the Refine Mask dialog box. Click once or twice in each area where background
color shows., When you erase an area, the Refine Mask feature erases similar
colors, cleaning up more of the mask for you. Be careful not to erase the
refinements you made to the hair edge. You can undo a step or use the Refine
Radius tool to restore the edge if necessary.

15 Select Decontaminate Colors, and move the Amount stider to 85%. Choose
New Layer With Layer Mask from the Output To menu. Then click OK.

(] marmvbar Satngs

16 In the Layers panel, make the Magazine Background layer visible. The madel
appears in front of an orange patterned background.
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Creating a quick mask

You'll create a quick mask to change the color of the glasses frames. First, you'll
clean up the Layers panel.

1

Layers ' Channels o Paths ~3

Hide the Magazine Background layer so you
can focus on the model. Then delete the fowmRs o T AR O
Layer 0 and Layer 0 copy layers. Click Yes or e S
Delete to confirm deletion of the layers or their
masks, if prompted; you do not need to apply
the mask to the current layer because Layer 0
copy 2 already has the mask applied.
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Double-click the Layer 0 copy 2 layer name,
and rename it Medel.

Click the Edit In Quick Mask Mode button in the Tools panel. (By default,
you have been working in Standard mode.)

1n Quick Mask mode, a red overlay appears as you make a selection, masking the
area outside the selection the way a rubylith, or red acetate, was used to mask images
in traditional print shops. You can apply changes only to the unprotected area that
is visible and selected. Notice that the highlight for the selected layer in the Layers
panel appears gray instead of blue, indicating you're in Quick Mask mode.

4
5

In the Tools panel, select the Brush tool {(«).

In the options bar, make sure that the mode is Normal. Open the Brush pop-up
panel, and select a small brush with a diameter of 13 px. Click outside the panel
to close it.

Paint the carpiece of the plasses frames, The area you paint will appear red, creating
a mask.

Continue painting with the Brush tool to mask the earpiece of the frames and the
frame around the lenses. Reduce the brush size to paint around the lenses. Don’t
wortry about the hair overlapping the earpiece; go ahead and paint over it.
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In Quick Mask mode, Photoshop automatically defaults to Grayscale mode, with a
foreground color of black and a background color of white. When using a painting
| | _ or editing tool in Quick Mask mode, keep these principles in mind: 1

1
i
! || i * Painting with black adds to the mask (the red overlay) and decreases the
l selected area.

« DPainting with white erases the mask (the red overlay) and increases the
| selected area.

Y

» Painting with gray partially adds to the mask.

B Click the Edit [n Standard Mode button to exit Quick Mask Mode.

alpha-channel mask, Photoshop discards the temporary mask once it is converted
il to a selection.

|

1 The unmasked area is selected. Unless you save a quick mask as a more permanent
|
]

| 9 Choose Select > Inverse to select the area you originally masked.

R -|i; i ' 10 Choose Image > Adjustments > Hue/Saturation.

':":i,_ i ' 11 In the Hue/Saturation dialog box, change the Hue to 70. The new green color fills
o e the glasses frame. Click OK.

Ughiress:

b

|| 12 Choose Select > Deselect.

'} | 13 Save your work so far.

Manipulating an image with Puppet Warp

The Puppet Warp feature gives you flexibility in manipulating an image. You can
reposition areas, such as hair or an arm, just as you might pull the strings on a
puppet. Place pins wherever you want to control movement. You'll use Puppet :
Warp to tilt the model’s head back, so he appears to be looking up.
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1 Zoom out so you can see the entire model.
2 With the Model layer selected in the Layers panel, choose Edit > Puppet Warp.

A mesh appears over the visible areas in the layer—in this case, the mesh appears over
the model. You'll use the mesh to place pins where you want to control movement
(or to ensure there is no movement),

3 Click around the edges of the shirt. Each time you click, Puppet Warp adds
a pin. Approximately 10 pins should work.

The pins you've added around the shirt will keep it in place as you tilt the head.

4 Select the pin at the nape of the neck. A white dot appears in the center
of the pin to indicate that it's selected.

'
- r
Hﬁ*}i
1

Pt
i
£ !

§ DPress Alt (Windows] ar Option (Mac OS). A larger circle appears around the pin
and a curved double arrow appears next to it. Continue pressing Alt or Option
as you drag the pointer to rotate the head backwards. You can see the angle of
rotation in the options bar; you can enter 135 there to rotate the head back.

@ Note: Be careful not
to Ait-click or Option-
click the dot ftself, or
you'li delete the pin.
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i3 | 6 When you're satisfied with the rotation, click the Commit Puppet Warp button (+)
[ in the options bar, or press Enter or Return.

: | ! 7 Save your work so far.

Working with channels

i Just as different information in an image is stored on different layers, channels also
let you access specific kinds of information. Alpha channels store selections as gray-

1 scale images. Color information channels store information about each color in

1 an image; for example, an RGB image automatically has red, green, blue, and

composite channels.

To avoid confusing channels and layers, think of channels as containing an image’s
i | l | color and selection information; think of layers as containing painting and effects.

a1 I You'll use an alpha channel to create a shadow for the model. Then, you'll convert
| _ the image to CMYK mode and use the Black channel to add color highlights to
{ ] 1 the hair.

! f | | Using an alpha channel to create a shadow

1 | You've already created a mask of the model. To create a shadow, you want to essen-
| | tially duplicate that mask and then shift it. You'll use an alpha channel to make that
St | possible.

g ‘k _ i l | 1 In the Layers panel, Ctri-click {Windows) or Command-click (Mac OS) the layer
ok ' icon in the Model layer. The masked area is selected.

R
; -
2 Ty A 'y | -"I !

Choose Select > Save Selection. In the Save Selection dialog box, make sure
New is chosen in the Channel menu. Then name the channel Model Outline,
and click OK.

-
»~

R AT

Pocument: | 08Working.psd |
3

Channe'z | New

Ondial

() New thannsl
Add to Cranviel
Subtracs frem Channel
[ntersect with Channel
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Nothing changes in the Layers panel or in the image window. However,
a new channel named Model Outline has been added to the Channels panel.

3 Click the Create A New Layer icon () at the bottom of the Layers panel. Drag
the new layer below the Model layer, so that the shadow will be below the image
of the model. Then double-click the new layer's name, and rename it Shadow.

4 With the Shadow layer selected, choose Select > Refine Edge. In the Refine Edge
dialog box, move the Shift Edge slider to +36%. Then click OK.

I3 ﬁ Mgazine Bis hgroasd

5 Choose Edit > Fill. In the Fill dialog box, choose Black from the Use-menu, and then

click OK.

The Shadow layer displays a filled-in black outline of the model. Shadows aren’t
usually as dark as the person that casts them. You'll reduce the layer opacity.

6 In the Layers panel, change the layer opacity to 30%.

Blending -

[[] Presetve Trnsparency

Layrrs | Chatinels (| Paths, -
mxed @0 T
immu:__-__":' Dracity 30% [
e B2 B FUL - 1008 |~
o

2 iE]J g i a2 A

e #agazine Background

The shadow is in exactly the same position as the model, where it can’t be seen.

You'll shift it.

7 Choose Select > Deselect to remove the selection.
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|| 8 Choose Edit > Transform > Rotate. Rotate the shadow by hand, or enter -15°

: : in the Rotate field in the options bar. Then drag the shadow to the left, or enter
845 in the X field in the options bar. Click the Commit Transform button (V)
in the options bar, or press Enter or Return, to accept the transformation.
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9 Choose File > Save to save your work so far. 1

Adjusting an individual channel

You're almost done with the magazine cover image. All that remains is to add color
highlights to the model’s hair. You'll convert the image to CMYK mode so you can §

take advantage of the Black channel to do just that.

1 Select the Mode! layer in the Layers panel. 1
2 Choose Image > Mode > CMYK Colox. Click Don’t Merge in the dialog box 1
that appears, because you want to keep your layers intact. Click QK if you're

prompted about color profiles.
3 Alt-click (Windows) or Option-click (Mac 0S) the visibility icon for the Model
layer to hide the other layers.
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About alpha channels

If you work in Photoshop very long, you're bound to work with alpha channels.
It's a good idea to know a few things about them.

e Animage can coniain up to 56 channels, including all color and alpha channels.
o Al channels are 8-bit grayscale images, capable of displaying 256 levels of gray.

« You can specify a name, color, mask option, and opacity for each channel. (The
opacity affects the preview of the channel, not the image.)

+ Alinew channels have the same dimenslons and number of pixels as the
original image.

¢  You can edit the maskin an alpha channel using the painting tools, editing
toals, and filters.

« You can convert alpha channels to spot-color channels,

4 Select the Channels tab. in the Channels panel, select the Black channel. Then
choose Duplicate Channel from the Channels panel menu. Name the channel
Hair, and click OK.

Layees | Channots Talkes

Individual channels appear in grayscale. 1f more than one channel is visible
in the Channels panel, the channels appear in color.
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5 Make the Hair channel visible, and hide the Black channel. Then select the Hair
channel, and choose Image > Adjustments > Levels.

6 In the Levels dialog box, adjust the levels to move Black to 85, Midtones

to 1, and White to 165. Moving the Black and White points create contrast
in the hair. Click OK.

A
_ﬂpnnrfs-T!
s A

7 With the Hair channel still selected, choose Image > Adjustments > Invert.
The channel appears white against a black background.

B Select the Brush tool, and click the Switch Foreground And Background Colors
icon in the Tools panel to make the Foreground color black. Then paint over
the glasses, eyes, and anything in the channel that isn't hair.
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9 Click the Load Channel As Selection icon at the bottom of the Channels panel.

10 Select the Layers tab. In the Layers panel, select the Model layer.

Layrs | Channel= ™ Pal:

-amc
'Mmh L‘!k:-a/'s'ﬂ

o @ﬂ [ &
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E’-'}_“i Magazne Lxkground

11 Choose Select > Refine Edge. In the Refine Edge dialog box, move the Feather
slider to 1.2 px, and then click OK.

12 Choose Image > Adjustments > Hue/Saturation. Select Colorize, and then move
the sliders as follows, and click OK:

s Hue: 230
= Saturation: 56

» Lightness: 11

il Prevet | Custom

' -
| | Haster &

Hue:
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|
, i | 13 Choose Image > Adjustments > Levels, In the Levels dialog box, move the sliders

i so that the Black slider is positioned where the blacks peak, the White slider
‘ ' where the whites peak, and the Midtones in between. Then click OK.
|I | We used the values 58, 1.65, 255, but your values may vary.
| |
[

e R —
Ol
L%,

14 In the Layers panel, make the Shadow and Magazine Background layers visible 1

15 Choose Select > Deselect. :

. 16 Choose File > Save. _?
Your magazine cover is ready to go! : 1
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Review questions

What is the benefit of using a quick mask?

What happens to a quick mask when you deselect it?

When you save a selection as a mask, where is the mask stored?

How can you edit a mask in a channel once you've saved it?

i A W N -

How do channels differ from layers?

Review answers

e r——— e a3

1 Quick masks are helpful for creating quick, one-time selections. In addition, using
a quick mask is an easy way to edit a selection using the painting tools.

2 'The quick mask disappears when you deselect it.

3 Masks are saved in channels, which can be thought of as storage areas for color and
selection information in an image.

! 4 You can paint on a mask in a channel using black, white, and shades of gray.

5 5 Channels are used as storage areas for saved selections. Unless you explicitly display
a channel, it does not appear in the image or print. Layers can be used to isolate
various parts of an image so that they can be edited as discrete objects with the
painting or editing tools or other effects.

rIll—. =
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